如何安装 libcgi-application-plugin-config-simple-perl Debian 10

了解如何安装 libcgi-application-plugin-config-simple-perl Debian 10 通过本教程。 libcgi-application-plugin-config-simple-perl 是提供配置的模块

介绍

在本教程中我们学习如何安装 libcgi-application-plugin-config-simple-perl 在 Debian 10.

什么是 libcgi-application-plugin-config-simple-perl

libcgi-application-plugin-config-simple-perl 是:

CGI::Application::Plugin::Config::Simple 充当 Config::Simple 的插件,以便在 CGI::Application 模块中轻松使用。 它不提供 Config::Simple 中可用的所有方法,而是提供对配置变量的轻松访问。 但是,如果您想使用它的全部功能,它确实提供对创建的底层 Config::General 对象的直接访问。

有三种安装方法 libcgi-application-plugin-config-simple-perl 在 Debian 10.我们可以使用 apt-get, aptaptitude。 在以下部分中,我们将描述每种方法。 您可以选择其中之一。

使用 apt-get 安装 libcgi-application-plugin-config-simple-perl

更新 apt 数据库 apt-get 使用以下命令。

更新apt数据库后,我们可以安装 libcgi-application-plugin-config-simple-perl 使用 apt-get 通过运行以下命令:

sudo apt-get -y install libcgi-application-plugin-config-simple-perl

使用 apt 安装 libcgi-application-plugin-config-simple-perl

更新 apt 数据库 apt 使用以下命令。

更新apt数据库后,我们可以安装 libcgi-application-plugin-config-simple-perl 使用 apt 通过运行以下命令:

sudo apt -y install libcgi-application-plugin-config-simple-perl

使用 aptitude 安装 libcgi-application-plugin-config-simple-perl

如果您想遵循此方法,您可能需要先安装 aptitude,因为 aptitude 通常不会默认安装 Debian。 更新 apt 数据库 aptitude 使用以下命令。

更新apt数据库后,我们可以安装 libcgi-application-plugin-config-simple-perl 使用 aptitude 通过运行以下命令:

sudo aptitude -y install libcgi-application-plugin-config-simple-perl

如何卸载 libcgi-application-plugin-config-simple-perl Debian 10

仅卸载 libcgi-application-plugin-config-simple-perl 打包我们可以使用以下命令:

sudo apt-get remove libcgi-application-plugin-config-simple-perl

卸载 libcgi-application-plugin-config-simple-perl 及其依赖项

卸载 libcgi-application-plugin-config-simple-perl 及其不再需要的依赖项 Debian 10、我们可以使用下面的命令:

sudo apt-get -y autoremove libcgi-application-plugin-config-simple-perl

删除 libcgi-application-plugin-config-simple-perl 配置和数据

去除 libcgi-application-plugin-config-simple-perl 配置和数据来自 Debian 10.我们可以使用如下命令:

sudo apt-get -y purge libcgi-application-plugin-config-simple-perl

删除 libcgi-application-plugin-config-simple-perl 配置、数据及其所有依赖项

我们可以使用下面的命令来删除 libcgi-application-plugin-config-simple-perl 配置、数据及其所有依赖项,我们可以使用以下命令:

sudo apt-get -y autoremove --purge libcgi-application-plugin-config-simple-perl

依赖关系

libcgi-application-plugin-config-simple-perl 具有以下依赖项:

参考

概括

在本教程中我们学习如何安装 libcgi-application-plugin-config-simple-perl 封装在 Debian 10. 使用不同的包管理工具: apt, apt-getaptitude