如何安装 libcgi-application-plugin-captcha-perl Debian 10

了解如何安装 libcgi-application-plugin-captcha-perl Debian 10 通过本教程。 libcgi-application-plugin-captcha-perl 是在 CGI 中提供 CAPTCHA 支持的模块

介绍

在本教程中我们学习如何安装 libcgi-application-plugin-captcha-perl 在 Debian 10.

什么是 libcgi-application-plugin-captcha-perl

libcgi-application-plugin-captcha-perl 是:

CGI::Application::Plugin::CAPTCHA 允许程序员在其 CGI::Application 派生的 Web 应用程序中轻松添加和验证 CAPTCHA。 验证码(或区分计算机和人类的全自动公共图灵测试)是带有随机字符串的图像。 用户必须成功输入随机字符串才能提交表单。 对于人类来说,这是一个简单(但烦人)的过程,但对于表单填充脚本来说,在不集成某种 OCR 的情况下完成该过程要困难得多。

验证码并不是一个完美的解决方案。 任何熟练、勤奋的破解者最终都能够绕过验证码,但它应该能够关闭普通的脚本小子。

当使用此模块创建验证码时,原始图像数据将从您的 Web 应用程序传输到客户端浏览器。 包含校验和的 cookie 也会与图像一起传输。 当客户端提交表单进行处理(以及对随机字符串的验证)时, captcha_verify() 会生成用户输入的验证字符串的校验和。 如果新生成的校验和与 cookie 中找到的校验和匹配,则假定已成功输入验证码,并且允许用户继续处理其表单。

有三种安装方法 libcgi-application-plugin-captcha-perl 在 Debian 10.我们可以使用 apt-get, aptaptitude。 在以下部分中,我们将描述每种方法。 您可以选择其中之一。

使用 apt-get 安装 libcgi-application-plugin-captcha-perl

更新 apt 数据库 apt-get 使用以下命令。

更新apt数据库后,我们可以安装 libcgi-application-plugin-captcha-perl 使用 apt-get 通过运行以下命令:

sudo apt-get -y install libcgi-application-plugin-captcha-perl

使用 apt 安装 libcgi-application-plugin-captcha-perl

更新 apt 数据库 apt 使用以下命令。

更新apt数据库后,我们可以安装 libcgi-application-plugin-captcha-perl 使用 apt 通过运行以下命令:

sudo apt -y install libcgi-application-plugin-captcha-perl

使用 aptitude 安装 libcgi-application-plugin-captcha-perl

如果您想遵循此方法,您可能需要先安装 aptitude,因为 aptitude 通常不会默认安装 Debian。 更新 apt 数据库 aptitude 使用以下命令。

更新apt数据库后,我们可以安装 libcgi-application-plugin-captcha-perl 使用 aptitude 通过运行以下命令:

sudo aptitude -y install libcgi-application-plugin-captcha-perl

如何卸载 libcgi-application-plugin-captcha-perl Debian 10

仅卸载 libcgi-application-plugin-captcha-perl 打包我们可以使用以下命令:

sudo apt-get remove libcgi-application-plugin-captcha-perl

卸载 libcgi-application-plugin-captcha-perl 及其依赖项

卸载 libcgi-application-plugin-captcha-perl 及其不再需要的依赖项 Debian 10、我们可以使用下面的命令:

sudo apt-get -y autoremove libcgi-application-plugin-captcha-perl

删除 libcgi-application-plugin-captcha-perl 配置和数据

去除 libcgi-application-plugin-captcha-perl 配置和数据来自 Debian 10.我们可以使用如下命令:

sudo apt-get -y purge libcgi-application-plugin-captcha-perl

删除 libcgi-application-plugin-captcha-perl 配置、数据及其所有依赖项

我们可以使用下面的命令来删除 libcgi-application-plugin-captcha-perl 配置、数据及其所有依赖项,我们可以使用以下命令:

sudo apt-get -y autoremove --purge libcgi-application-plugin-captcha-perl

依赖关系

libcgi-application-plugin-captcha-perl 具有以下依赖项:

参考

概括

在本教程中我们学习如何安装 libcgi-application-plugin-captcha-perl 封装在 Debian 10. 使用不同的包管理工具: apt, apt-getaptitude