如何安装 libapache-ssllookup-perl Debian 11

在本教程中,我们学习如何安装 libapache-ssllookup-perl Debian 11. libapache-ssllookup-perl 是 Perl 处理程序和 mod_ssl 公共 API 之间的粘合层

介绍

在本教程中我们学习如何安装 libapache-ssllookup-perl 在 Debian 11.

什么是 libapache-ssllookup-perl

libapache-ssllookup-perl 是:

Apache::SSLLookup 是 Perl 处理程序和 mod_ssl 公共 API 之间的粘合层。 正常情况下,您可以使用 $r->subprocess_env() 来收集有关 mod_ssl 的信息。 为了 example,

$request_is_over_ssl = $r->subprocess_env('HTTPS');

然而,这只有在 mod_ssl 运行其修复程序之后才有可能 – 也就是说,Perl 处理程序只能在 PerlResponsePhase 或更高版本中准确检查 subprocess_env 表中的 mod_ssl 信息。

该模块允许您在请求周期的任何时刻直接通过其公共 C API 查询 mod_ssl。 但当然不使用 C。

有三种安装方法 libapache-ssllookup-perl 在 Debian 11.我们可以使用 apt-get, aptaptitude。 在以下部分中,我们将描述每种方法。 您可以选择其中之一。

使用 apt-get 安装 libapache-ssllookup-perl

更新 apt 数据库 apt-get 使用以下命令。

更新apt数据库后,我们可以安装 libapache-ssllookup-perl 使用 apt-get 通过运行以下命令:

sudo apt-get -y install libapache-ssllookup-perl

使用 apt 安装 libapache-ssllookup-perl

更新 apt 数据库 apt 使用以下命令。

更新apt数据库后,我们可以安装 libapache-ssllookup-perl 使用 apt 通过运行以下命令:

sudo apt -y install libapache-ssllookup-perl

使用 aptitude 安装 libapache-ssllookup-perl

如果您想遵循此方法,您可能需要先安装 aptitude,因为 aptitude 通常不会默认安装 Debian。 更新 apt 数据库 aptitude 使用以下命令。

更新apt数据库后,我们可以安装 libapache-ssllookup-perl 使用 aptitude 通过运行以下命令:

sudo aptitude -y install libapache-ssllookup-perl

如何卸载 libapache-ssllookup-perl Debian 11

仅卸载 libapache-ssllookup-perl 打包我们可以使用以下命令:

sudo apt-get remove libapache-ssllookup-perl

卸载 libapache-ssllookup-perl 及其依赖项

卸载 libapache-ssllookup-perl 及其不再需要的依赖项 Debian 11、我们可以使用下面的命令:

sudo apt-get -y autoremove libapache-ssllookup-perl

删除 libapache-ssllookup-perl 配置和数据

去除 libapache-ssllookup-perl 配置和数据来自 Debian 11.我们可以使用如下命令:

sudo apt-get -y purge libapache-ssllookup-perl

删除 libapache-ssllookup-perl 配置、数据及其所有依赖项

我们可以使用下面的命令来删除 libapache-ssllookup-perl 配置、数据及其所有依赖项,我们可以使用以下命令:

sudo apt-get -y autoremove --purge libapache-ssllookup-perl

依赖关系

libapache-ssllookup-perl 具有以下依赖项:

参考

概括

在本教程中我们学习如何安装 libapache-ssllookup-perl 封装在 Debian 11.使用不同的包管理工具: apt, apt-getaptitude