如何安装 libalien-wxwidgets-perl Debian 10

了解如何安装 libalien-wxwidgets-perl Debian 10 通过本教程。 libalien-wxwidgets-perl 是用于定位 wxWidgets 二进制文件的 Perl 模块

介绍

在本教程中我们学习如何安装 libalien-wxwidgets-perl 在 Debian 10.

什么是 libalien-wxwidgets-perl

libalien-wxwidgets-perl 是:

Alien::WxWidgets 是一个简单的 Perl 模块,用于检测已安装的 wxWidgets 的配置设置。 它有助于帮助构建需要 wxWidgets 的模块,提供必要的编译相关信息,如相关链接器和编译器标志。

有三种安装方法 libalien-wxwidgets-perl 在 Debian 10.我们可以使用 apt-get, aptaptitude。 在以下部分中,我们将描述每种方法。 您可以选择其中之一。

更新 apt 数据库 apt-get 使用以下命令。

更新apt数据库后,我们可以安装 libalien-wxwidgets-perl 使用 apt-get 通过运行以下命令:

sudo apt-get -y install libalien-wxwidgets-perl

更新 apt 数据库 apt 使用以下命令。

更新apt数据库后,我们可以安装 libalien-wxwidgets-perl 使用 apt 通过运行以下命令:

sudo apt -y install libalien-wxwidgets-perl

如果您想遵循此方法,您可能需要先安装 aptitude,因为 aptitude 通常不会默认安装 Debian。 更新 apt 数据库 aptitude 使用以下命令。

更新apt数据库后,我们可以安装 libalien-wxwidgets-perl 使用 aptitude 通过运行以下命令:

sudo aptitude -y install libalien-wxwidgets-perl

仅卸载 libalien-wxwidgets-perl 打包我们可以使用以下命令:

sudo apt-get remove libalien-wxwidgets-perl

卸载 libalien-wxwidgets-perl 及其依赖项

卸载 libalien-wxwidgets-perl 及其不再需要的依赖项 Debian 10、我们可以使用下面的命令:

sudo apt-get -y autoremove libalien-wxwidgets-perl

删除 libalien-wxwidgets-perl 配置和数据

去除 libalien-wxwidgets-perl 配置和数据来自 Debian 10.我们可以使用如下命令:

sudo apt-get -y purge libalien-wxwidgets-perl

删除 libalien-wxwidgets-perl 配置、数据及其所有依赖项

我们可以使用下面的命令来删除 libalien-wxwidgets-perl 配置、数据及其所有依赖项,我们可以使用以下命令:

sudo apt-get -y autoremove --purge libalien-wxwidgets-perl

依赖关系

libalien-wxwidgets-perl 具有以下依赖项:

参考

概括

在本教程中我们学习如何安装 libalien-wxwidgets-perl 封装在 Debian 10. 使用不同的包管理工具: apt, apt-getaptitude