如何安装 libanyevent-websocket-client-perl Debian 11

在本教程中,我们学习如何安装 libanyevent-websocket-client-perl Debian 11. libanyevent-websocket-client-perl 是 AnyEvent 的 Perl WebSocket 客户端

介绍

在本教程中我们学习如何安装 libanyevent-websocket-client-perl 在 Debian 11.

什么是 libanyevent-websocket-client-perl

libanyevent-websocket-client-perl 是:

AnyEvent::WebSocket::Client 提供了一个与 Web 服务器交互的接口,该服务器通过 AnyEvent 上下文中的 WebSocket 协议提供服务。 它使用 Protocol::WebSocket 而不是重新发明轮子。 如果您想要更精细的控制,您可以直接使用 AnyEvent 和 Protocol::WebSocket,但如果没有必要,那么此类可能会节省您一些时间。

推荐的 API 已添加到版本 0.12 的 AnyEvent::WebSocket::Connection 类中,因此建议您在使用此模块时包含该版本。 旧版本的 API 已被弃用并删除。

有三种安装方法 libanyevent-websocket-client-perl 在 Debian 11.我们可以使用 apt-get, aptaptitude。 在以下部分中,我们将描述每种方法。 您可以选择其中之一。

使用 apt-get 安装 libanyevent-websocket-client-perl

更新 apt 数据库 apt-get 使用以下命令。

更新apt数据库后,我们可以安装 libanyevent-websocket-client-perl 使用 apt-get 通过运行以下命令:

sudo apt-get -y install libanyevent-websocket-client-perl

使用 apt 安装 libanyevent-websocket-client-perl

更新 apt 数据库 apt 使用以下命令。

更新apt数据库后,我们可以安装 libanyevent-websocket-client-perl 使用 apt 通过运行以下命令:

sudo apt -y install libanyevent-websocket-client-perl

使用 aptitude 安装 libanyevent-websocket-client-perl

如果您想遵循此方法,您可能需要先安装 aptitude,因为 aptitude 通常不会默认安装 Debian。 更新 apt 数据库 aptitude 使用以下命令。

更新apt数据库后,我们可以安装 libanyevent-websocket-client-perl 使用 aptitude 通过运行以下命令:

sudo aptitude -y install libanyevent-websocket-client-perl

如何卸载 libanyevent-websocket-client-perl Debian 11

仅卸载 libanyevent-websocket-client-perl 打包我们可以使用以下命令:

sudo apt-get remove libanyevent-websocket-client-perl

卸载 libanyevent-websocket-client-perl 及其依赖项

卸载 libanyevent-websocket-client-perl 及其不再需要的依赖项 Debian 11、我们可以使用下面的命令:

sudo apt-get -y autoremove libanyevent-websocket-client-perl

删除 libanyevent-websocket-client-perl 配置和数据

去除 libanyevent-websocket-client-perl 配置和数据来自 Debian 11.我们可以使用如下命令:

sudo apt-get -y purge libanyevent-websocket-client-perl

删除 libanyevent-websocket-client-perl 配置、数据及其所有依赖项

我们可以使用下面的命令来删除 libanyevent-websocket-client-perl 配置、数据及其所有依赖项,我们可以使用以下命令:

sudo apt-get -y autoremove --purge libanyevent-websocket-client-perl

依赖关系

libanyevent-websocket-client-perl 具有以下依赖项:

参考

概括

在本教程中我们学习如何安装 libanyevent-websocket-client-perl 封装在 Debian 11.使用不同的包管理工具: apt, apt-getaptitude