如何安装 japi-compliance-checker Debian 10

了解如何安装 japi-compliance-checker Debian 10 通过本教程。 japi-compliance-checker 是比较 Java 库 API 兼容性的工具

介绍

在本教程中我们学习如何安装 japi-compliance-checker 在 Debian 10.

什么是 japi-compliance-checker

japi 合规性检查器是:

Java API 合规性检查器 (Java ACC) 是一种用于检查 Java 库 API 的向后二进制和源代码级兼容性的工具。 该工具检查新旧版本的类声明,并分析可能破坏兼容性的更改:删除的方法、删除的类字段、添加的抽象方法等。二进制不兼容可能会导致使用旧版本构建的现有客户端崩溃或不正确的行为。当他们使用新库运行时。 源不兼容可能会导致新库版本的重新编译错误。 该工具适用于对确保向后兼容性感兴趣的库开发人员和操作系统维护人员,即允许旧客户端运行或使用新库版本重新编译。

有三种安装方法 japi-compliance-checker 在 Debian 10.我们可以使用 apt-get, aptaptitude。 在以下部分中,我们将描述每种方法。 您可以选择其中之一。

使用 apt-get 安装 japi-compliance-checker

更新 apt 数据库 apt-get 使用以下命令。

更新apt数据库后,我们可以安装 japi-compliance-checker 使用 apt-get 通过运行以下命令:

sudo apt-get -y install japi-compliance-checker

使用 apt 安装 japi-compliance-checker

更新 apt 数据库 apt 使用以下命令。

更新apt数据库后,我们可以安装 japi-compliance-checker 使用 apt 通过运行以下命令:

sudo apt -y install japi-compliance-checker

使用 aptitude 安装 japi-compliance-checker

如果您想遵循此方法,您可能需要先安装 aptitude,因为 aptitude 通常不会默认安装 Debian。 更新 apt 数据库 aptitude 使用以下命令。

更新apt数据库后,我们可以安装 japi-compliance-checker 使用 aptitude 通过运行以下命令:

sudo aptitude -y install japi-compliance-checker

如何卸载 japi-compliance-checker Debian 10

仅卸载 japi-compliance-checker 打包我们可以使用以下命令:

sudo apt-get remove japi-compliance-checker

卸载 japi-compliance-checker 及其依赖项

卸载 japi-compliance-checker 及其不再需要的依赖项 Debian 10、我们可以使用下面的命令:

sudo apt-get -y autoremove japi-compliance-checker

删除 japi-compliance-checker 配置和数据

去除 japi-compliance-checker 配置和数据来自 Debian 10.我们可以使用如下命令:

sudo apt-get -y purge japi-compliance-checker

删除 japi-compliance-checker 配置、数据及其所有依赖项

我们可以使用下面的命令来删除 japi-compliance-checker 配置、数据及其所有依赖项,我们可以使用以下命令:

sudo apt-get -y autoremove --purge japi-compliance-checker

依赖关系

japi-compliance-checker 具有以下依赖项:

参考

概括

在本教程中我们学习如何安装 japi-compliance-checker 封装在 Debian 10. 使用不同的包管理工具: apt, apt-getaptitude