如何安装lua5.4 Ubuntu 21.04

lua5.4 是简单、可扩展、可嵌入的编程语言

介绍

在本教程中我们学习如何安装 lua5.4 在 Ubuntu 21.04。

什么是 lua5.4

Lua 是一种强大的轻量级编程语言,专为扩展应用程序而设计。 该语言引擎可作为库进行访问,具有 C API,允许应用程序与 Lua 程序交换数据,并使用 C 函数扩展 Lua。 Lua 还通过提供的简单命令行解释器用作通用的独立语言。

该软件包包含 Lua 命令行解释器和字节码编译器。 如果您正在开发或使用 Lua 脚本,请安装它。

有三种安装方式 lua5.4 在 Ubuntu 21.04。 我们可以用 apt-get, aptaptitude。 在以下部分中,我们将描述每种方法。 您可以选择其中之一。

使用apt-get安装lua5.4

更新 apt 数据库 apt-get 使用以下命令。

更新apt数据库后,我们可以安装 lua5.4 使用 apt-get 通过运行以下命令:

sudo apt-get -y install lua5.4

使用apt安装lua5.4

更新 apt 数据库 apt 使用以下命令。

更新apt数据库后,我们可以安装 lua5.4 使用 apt 通过运行以下命令:

sudo apt -y install lua5.4

使用 aptitude 安装 lua5.4

如果您想遵循此方法,您可能需要先安装 aptitude,因为 aptitude 通常不会默认安装 Ubuntu。 更新 apt 数据库 aptitude 使用以下命令。

更新apt数据库后,我们可以安装 lua5.4 使用 aptitude 通过运行以下命令:

sudo aptitude -y install lua5.4

如何卸载lua5.4 Ubuntu 21.04

仅卸载 lua5.4 打包我们可以使用以下命令:

sudo apt-get remove lua5.4

卸载lua5.4及其依赖项

卸载 lua5.4 及其不再需要的依赖项 Ubuntu 21.04,我们可以使用以下命令:

sudo apt-get -y autoremove lua5.4

删除lua5.4配置和数据

去除 lua5.4 配置和数据来自 Ubuntu 21.04我们可以使用以下命令:

sudo apt-get -y purge lua5.4

删除 lua5.4 配置、数据及其所有依赖项

我们可以使用下面的命令来删除 lua5.4 配置、数据及其所有依赖项,我们可以使用以下命令:

sudo apt-get -y autoremove --purge lua5.4

参考

概括

在本教程中我们学习如何安装 lua5.4 使用不同的包管理工具,如 apt、apt-get 和 aptitude。